Kwetsbaarheid gemeld in open source codec

Dit artikel delen:

Beveiligingsinstanties Secunia en FrSIRT waarschuwen voor een kwetsbaarheid in 'zlib'. Die open source codec wordt onder meer meegeleverd bij veel Linux- en BSD-distributies.

De kwetsbaarheid maakt een buffer overflow mogelijk. Zlib wordt intensief gebruikt in X-Box spelcomputers, mobiele telefoons en OpenSSH. De zwakke plek is geconstateerd in versie 1.2.2 van zlib, maar strekt zich wellicht uit tot eerdere versies van de codec.

Mark Adler, medeauteur van zlib is bezig met het prepareren en testen van versie 1.2.3 die de kwetsbaarheid moet verhelpen. Er zijn thans al fixes voor de Linux-distro’s van onder meer Suse, Red Hat en Debian.

x

Om te kunnen beoordelen moet u ingelogd zijn:

Dit artikel delen:

Stuur dit artikel door

Uw naam ontbreekt
Uw e-mailadres ontbreekt
De naam van de ontvanger ontbreekt
Het e-mailadres van de ontvanger ontbreekt

×
×
article 2005-07-08T12:12:00.000Z René Rippen
Wilt u dagelijks op de hoogte worden gehouden van het laatste ict-nieuws, achtergronden en opinie?
Abonneer uzelf op onze gratis nieuwsbrief.