Managed hosting door True

Discussie

Deze opinie is van een externe deskundige. De inhoud vertegenwoordigt dus niet noodzakelijk het gedachtegoed van de redactie.

‘Afkappen van Android-patches raakt bedrijven’

 

Elke werkdag behandelt Computable een technisch onderwerp waarover lezers kunnen discussiëren. Vandaag gaat het over het afkappen van securitypatches voor Android vóór versie 4.4. Maakt dit bedrijven onveiliger of gaan zij toch met nieuwe releases (en lease-toestellen) mee?

Google blijkt voorgaande - en veelgebruikte - Android-versies niet langer te ondersteunen met securitypatches voor kwetsbaarheden in de oudere Android-browser. Maar liefst 60 procent van de huidige Android-toestellen valt hiermee buiten de boot. Het gaat specifiek om patches voor browserkern WebView, die zorgt voor de rendering van webpagina’s. Android-versies van vóór 4.4 (codenaam KitKat) krijgen geen patches meer. In KitKat is het oude WebView vervangen door een afgeleide van Chromium, de open source-uitvoering van Google’s desktopbrowser Chrome. Raakt dit patchbeleid van Google zakelijke Android-gebruiker wel of juist niet? Bij leaseconstructies komen er immers om de paar jaar nieuwe toestellen - met daarop nieuwe Android-versies.

Dit artikel is afkomstig van Computable.nl (https://www.computable.nl/artikel/5216715). © Jaarbeurs IT Media.

?


Lees meer over



Lees ook


 

Reacties

Dit zal voor velen, niet alleen organisaties een teleurstelling zijn. De meeste mobiele toestellen worden gekocht om 2-3 jaar mee te gaan. Versie 4.4 is van juli 2013 en de versie daarvoor 4.3 van november 2012 en dat is pas 2 jaar en 2 maanden geleden. De cyclus lijkt erg kort en zou naar mijn mening op minimaal 3 jaar moeten liggen.
De meeste organisaties die android gebruiken zullen wel gebruik maken van een MDM systeem, waardoor security patches op bedrijfsapplicaties die binnen de MDM container worden aangeboden niet direct worden geraakt, maar als organisatie ga je natuurlijk wel nadenken over de vervanging.
Jellybean versie 4.1 en 4.2 beslaan nog 45% van de android markt, terwijl versie 4.4 op 25% van android toestellen wordt gebruikt. http://www.statista.com/statistics/271774/share-of-android-platforms-on-mobile-devices-with-android-os/
Een beter lifecycle management zou bij android niet misstaan. Een versie binnen 3 jaar afschrijven is veel te kort.

Het probleem zit minder in het OS als in de apps.
Om het ecosysteem met android te verbeteren moet het kompleet op de schop, root-toegang en updates zijn kreupel want afwezig.
Als normale gebruiker heb je nauwelijks inzicht in of invloed op de veiligheidsinstellingen, je krijgt echter een batterij bloatware van Google meegeleverd die ook nog al jouw digitale sporen wil vervolgen en zich zonder grondige ingrepen niet verwijderen laat.
Je mag je afvragen of dit platform wel voor zakelijk gebruik geschikt is.

Een OS met ecosysteem afschrijven in minder da 3 jaar is belachelijk, ook als het om 'wegwerp' artikelen als smartphones gaat. Daarbij komt dat we niet alleen afhankelijk zijn van Google voor het ontwikkelen en ondersteunen van Android, maar ook van de vele leveranciers van telefoons voor het testen, packagen en uitrollen van updates. Hele nieuwe releases of functionaliteiten kan ik me iets bij voorstellen, maar regulier onderhoud en security fixes moet je toch standaard minimaal 3 jaar kunnen verwachten.
Dit is een sterk argument tegen toepassen van Android in zakelijke omgevingen, ook (vooral) als BYOD.

Het hele ecosysteem van Android is gericht op de consument en vooral op het verzamelen van gegevens van die consument.
Dat druist eenvoudigweg tegen een zakelijke toepassing in.

Ook als Google een update zou uitbrengen heeft dat weinig zin, de meeste fabrikanten zullen hem toch niet als firmware upgrade verspreiden.

@Willem: "Versie 4.4 is van juli 2013 en de versie daarvoor 4.3 van november 2012"
Echter, als je in juli 2013 een Android mobieltje koopt, is het geenszins zeker dat daar ook al 4.4 op staat! Ik heb mijn huidige mobieltje in juli 2014 gekocht. En wat stond (en staat) daar op? Android 4.1! Blijkbaar lag dit mobieltje al een paar jaar in de schappen (en heb ik waarschijnlijk teveel betaald), maar goed - ik moest meteen een nieuwe hebben i.v.m. de vakantie, en we wonen niet allemaal in de grote stad met een phone-house om de hoek.

Dat nu 4.x al niet meer wordt ondersteund, vind ik absurd en ronduit slecht: geef die mensen dan op zijn minst de mogelijkheid te updaten naar 4.4.

@Peter,

Ja, belachelijk eigenlijk, maar ook dat je als consument dus veel verstand moet hebben van een operating system, slaat nergens op, toch.
Je kunt van Apple zeggen wat je wilt, maar dat hebben ze goed voor elkaar. Er is ook weinig angst om te upgraden en er is een duidelijk beleid over welke hardware wel en niet wordt ondersteund.
Ik heb al een gemerkt dat updaten van een Android toestel soms wel kan, maar meestal niet. begrijp niet dat die toestelbouwer zich zo vastpinnen op een O/S versie.Is dit het nadeel van 'open source'?

Vacatures

Stuur door

Stuur dit artikel door

Je naam ontbreekt
Je e-mailadres ontbreekt
De naam van de ontvanger ontbreekt
Het e-mailadres van de ontvanger ontbreekt

×
×