Managed hosting door True
Onderstaande bijdrage is van een externe partij. De redactie is niet verantwoordelijk voor de geboden informatie.

WordPress sites gebruiken onveilige PHP-versie

 

WordPress sites gebruiken onveilige PHP-versie

Het is van maatschappelijk belang dat we met z’n allen het internet zo veilig mogelijk maken. Als ondernemers in de internetbranche geven we daar het goede voorbeeld in. Uit onderzoek van Savvii, gebaseerd op de gegevens van WordPress.org, blijkt echter dat 53% van de WordPress sites op een onveilige PHP-versie draait. Maar liefst 26% van het hele internet! Dit is een verontrustend hoog percentage.

Persbericht, Nijmegen, 20 april 2017

53% van de WordPress sites draait op een onveilige PHP-versie

Uit onderzoek van Savvii, gebaseerd op de gegevens van WordPress.org, blijkt dat meer dan de helft (53%) van de WordPress sites op een onveilige versie van PHP draait. Deze sites draaien op een versie van PHP waarvoor geen security releases meer uitkomen. Dat maakt deze versies erg kwetsbaar voor cybercriminelen. Momenteel worden alleen versies 5.6, 7.0 en 7.1 nog ondersteund.

Er zijn veel sites die op oude onveilige versies draaien die al jaren niet meer worden ondersteund. Zodra er geen security releases meer uitkomen voor een bepaalde versie, raadt The PHP Group streng aan om te upgraden naar een nieuwere versie. De veiligheid van de versie kan namelijk niet meer worden gewaarborgd.

Het is opmerkelijk dat er zoveel websites op oude PHP-versies draaien, zeker omdat het al lang van tevoren bekend is tot wanneer een versie ondersteund wordt. Van de meest recente versies van PHP staan deze data ook al vast.

Het is altijd de vraag bij wie de verantwoordelijkheid ligt om te upgraden naar een veiligere versie. Wie moet erachteraan? De eigenaar van een site, de ontwikkelaar van een site of leg je de verantwoordelijkheid bij de hostingpartij?

Volgens Alexander van Steen, Technical Mananger bij Savvii Managed WordPress Hosting, zouden alle drie de partijen moeten aansturen op een upgrade, vooral ook de hostingpartij. "Als hostingpartij kiezen wij er bewust voor om geen onveilige PHP-versies toe te laten. Al onze klanten hebben PHP-versie 5.6 of hoger. Wij informeren onze klanten ook actief over de voordelen van PHP 7.x en stellen ze in staat makkelijk te switchen van versie. 50% van de websites op onze servers draait al op PHP 7.x. Dat geeft een heel ander beeld dan de wereldwijde statistieken van WordPress sites, slechts 9%."

Het upgraden van de PHP-versie is niet alleen een belangrijk onderdeel om een website veilig te houden. Nieuwere PHP-versies bieden ook betere performance. Zo is PHP 7.x 2-3 keer zo snel dan PHP 5.6 en heeft daarmee een aantal belangrijke voordelen voor website-eigenaren. Een snellere website kan namelijk resulteren in meer tevreden bezoekers, meer tevreden klanten en een betere ranking in Google.

Dit artikel is afkomstig van Computable.nl (https://www.computable.nl/artikel/6005155). © Jaarbeurs IT Media.

?


Lees meer over


Vacatures

Stuur door

Stuur dit artikel door

Je naam ontbreekt
Je e-mailadres ontbreekt
De naam van de ontvanger ontbreekt
Het e-mailadres van de ontvanger ontbreekt

×
×